通达信多年趋向指标公式

2020-11-25 10:37核心: 通达信多年趋向指标公式

{使用说明:
1)强的上升趋势(牛市): PDI > MDI 和 ADX≥ 30
――走势有创新高的价格时,PDI上升,MDI下降。即若PDI金叉MDI显示买进信号。
(2)强的下降趋势(熊市):PDI < MDI 和 ADX≥ 30
――当MDI“金叉”PDI时,显示市场有新的空头卖出,因此为卖出信号。
当走势维持某种趋势时,PDI和MDI的交叉信号相当准确。(牛皮盘档时交叉则无效。)
当行情朝单方向发展时,无论涨跌势,ADX都会不断递增,当ADX大于上日,可以判断当前行情维持原势。特别是当PDA和ADX,或MDI和ADX同向上升时,表示当前涨或跌的趋势十分强劲。即ADX值若从高点转跌时,就将转势。
(3)略牛的盘整期:PDI > MDI 和 16 < ADX < 30
(4)略熊的盘整期:PDI < MDI 和16 < ADX < 30。
(5)静寂期: ADX ≤16和(PDI > MDI 或 PDI < MDI) 。
(6)在牛市ADX越大越强,但是大于60就要注意了,牛市将可能要回调。
上面的PDI你可理解成牛的力量;MDI理解成熊的力量;而ADX理解成牛熊力量对比的度量没有方向性。}
{60,DOTLINE,COLORMAGENTA;
30,DOTLINE,COLORMAGENTA;
15,DOTLINE,COLORMAGENTA;}
TTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),14);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),14);
PDI:DMP*100/TTR,COLORRED,NODRAW;
MDI:DMM*100/TTR,COLORBLUE,NODRAW;
STICKLINE(PDI>MDI,MDI,PDI,2,1),COLOR000088;
STICKLINE(PDI<=MDI,MDI,PDI,2,1),COLORBLUE;
STICKLINE(PDI>MDI AND MDI<15 AND PDI<15,PDI,MDI,2,0),COLORRED;
STICKLINE(PDISTICKLINE(PDI>MDI AND PDI>30 AND MDI>30,MDI,PDI,2,0),COLORRED;
STICKLINE(PDI30 AND MDI>30,MDI,PDI,2,0),COLORBLUE;
STICKLINE(PDI>MDI AND PDI>30 AND MDI<30,30,PDI,2,0),COLORRED;
STICKLINE(PDI>MDI AND PDI>15 AND MDI<15,15,MDI,2,0),COLORRED;
STICKLINE(PDI30 AND PDI<30,30,MDI,2,0),COLORBLUE;
STICKLINE(PDI15 AND PDI<15,15,PDI,2,0),COLORBLUE;
STICKLINE(CROSS(MDI,PDI),PDI,MDI,2,0),COLORCYAN;
STICKLINE(CROSS(MDI,30) AND PDISTICKLINE(CROSS(MDI,30) AND PDI30,PDI,MDI,2,0),COLORCYAN;
STICKLINE(PDI15,15,PDI,2,0),COLORCYAN;
STICKLINE(PDISTICKLINE(CROSS(PDI,MDI),PDI,MDI,2,0),COLOR0055FF;
STICKLINE(CROSS(PDI,30) AND PDI>MDI AND MDI<30,PDI,30,2,0),COLOR0055FF;
STICKLINE(CROSS(PDI,30) AND PDI>MDI AND MDI>30,PDI,MDI,2,0),COLOR0055FF;
STICKLINE(PDI>MDI AND CROSS(15,MDI) AND PDI>15,15,MDI,2,0),COLOR0055FF;
STICKLINE(PDI>MDI AND CROSS(15,MDI) AND PDI<15,PDI,MDI,2,0),COLOR0055FF;
ADX: EMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORWHITE;
ADXR:EMA(ADX,6),COLORYELLOW;

通达信多年趋向指标公式 003008开普检测 300030阳普医疗 600543莫高股份 000926福星股份 002320海峡股份 300262巴安水务 600332白云山 600282南钢股份 600250南纺股份 600389江山股份 688025杰普特 688528秦川物联 601318中国平安 002991甘源食品 300857协创数据 002852道道全