通达信操作止损线主图指标公式

2020-11-25 10:47核心: 通达信操作止损线主图指标公式

上收:=C;
压力:MA(REF(HHV(上收,30),1),2),COLORABFF46,LINETHICK3;
支撑:MA(REF(LLV(上收,30),1),2),COLORMAGENTA,LINETHICK3;
三一:=HIGH-(HIGH-LOW)*0.333,NODRAW;
二一:=HIGH-(HIGH-LOW)*0.5,NODRAW;
三二:=HIGH-(HIGH-LOW)*0.666,NODRAW;
实三一:=IF(CLOSE>OPEN,CLOSE-(CLOSE-OPEN)/3,OPEN-(OPEN-CLOSE)/3),NODRAW,COLORGREEN;
实体腰线:OPEN+(CLOSE-OPEN)*0.5,NODRAW;
实三二:=IF(CLOSE>OPEN,OPEN+(CLOSE-OPEN)/3,CLOSE+(OPEN-CLOSE)/3),NODRAW,COLORGREEN;
现价:IF(CURRBARSCOUNT<60,CONST(REF(C,0)),DRAWNULL),COLORGRAY,DOTLINE;
{-----------------------------------}
板块涨停数:=INSUM(HYBLOCK,'涨停板',1,0);
SJZH1:=STRCAT('【',HYBLOCK);
SJZH2:=STRCAT(SJZH1,'】涨停:');
SJZH3:=STRCAT(SJZH2,CON2STR(板块涨停数,0));
SJZH4:=STRCAT(SJZH3,' 只');
SJZH5:=STRCAT('【',HYBLOCK);
SJZH6:=STRCAT(SJZH5,'】无涨停');
SJZH7:=STRCAT(SJZH6,' ');
DRAWTEXT_FIX(板块涨停数=0 AND ISLASTBAR,0.2,0.01,1,'███████████████ '),COLORGREEN;
DRAWTEXT_FIX(板块涨停数=0 AND ISLASTBAR,0.2,0.01,1,SJZH7),COLORBLACK;
DRAWTEXT_FIX(板块涨停数>0 AND ISLASTBAR,0.2,0.01,1,'███████████████'),COLORLICYAN;
DRAWTEXT_FIX(板块涨停数>0 AND ISLASTBAR,0.2,0.01,1,SJZH4),COLORYELLOW;
{-----------------------------------}
{虚拟涨停K线}
ZTKX:=IF (ISLASTBAR=1 AND C>MA(C,60) AND C>MA(C,120) ,REF(CLOSE,1)*1.1,DRAWNULL),NODRAW;
STICKLINE(C/REF(C,1)>1.03 AND ZTKX>COST(85) AND C>REF(C,1) AND C>O,ZTKX,MAX(OPEN,CLOSE),-1,-1),COLOR00C0C0;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{-----------------------------------}
总额:AMOUNT/100000000,NODRAW;
明涨停价:C*1.099,NODRAW;
明后涨停价:C*1.199,NODRAW;
{-----------------------------------}
STICKLINE(C>=REF(C,1),LOW,HIGH,0.0,1),COLORRED;
STICKLINE(C>=REF(C,1),CLOSE,OPEN,2.5,1),COLORRED;
STICKLINE(CSTICKLINE(C{-----------------------------------}
HJ_1:=CLOSE/REF(CLOSE,1)>=1.099 AND CLOSE=HIGH;
HJ_2:=CLOSE/REF(CLOSE,1)<0.91 AND CLOSE=LOW;
HJ_3:=IF(NAMELIKE(1),1,0) OR IF(NAMELIKE(2),1,0);
HJ_4:=CLOSE/REF(CLOSE,1)>1.0491 AND CLOSE=HIGH;
HJ_5:=HJ_3 AND HJ_4;
HJ_6:=CLOSE/REF(CLOSE,1)<0.951 AND CLOSE=LOW;
HJ_7:=HJ_3 AND HJ_6;
HJ_8:=MA(VOL,5);
HJ_9:=MA(VOL,10);
HJ_10:=MA(VOL,20);
HJ_11:=COUNT(MA(CLOSE,10)>MA(CLOSE,5),10)=10 AND COUNT(HJ_9>HJ_8,10)=10;
HJ_12:=NOT(HJ_11);
HJ_13:=COUNT(MA(CLOSE,20)>MA(CLOSE,10),18)=18 AND COUNT(HJ_10>HJ_9,18)=18;
HJ_14:=NOT(HJ_13);
HJ_15:=COUNT(MA(CLOSE,20)>MA(CLOSE,10),30)=30;
HJ_16:=NOT(HJ_15);
HJ_17:=COUNT(MA(CLOSE,60)>MA(CLOSE,20),30)=30 AND MA(CLOSE,20)>MA(CLOSE,10);
HJ_18:=NOT(HJ_17);
HJ_19:=COUNT(MA(CLOSE,20)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,5),20)>15 AND COUNT(MA(CLOSE,5)>=MA(CLOSE,10),3)<3;
HJ_20:=NOT(HJ_19); 300553集智股份 002555三七互娱 600757长江传媒 300388国祯环保 06068睿见教育 300339润和软件 002262恩华药业 002612朗姿股份 000560我爱我家 601339百隆东方 300267尔康制药 300547川环科技 300477合纵科技 08111中国科技产业集团 002699美盛文化 600859王府井